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Introduction 
hT is data sheet provides technical overview of the Seavus Project Planner, and provides 
technical description of its features and functions.  
 

Seavus Project Planner is a desktop application that is used for creating project plans with 
main purpose to give project managers full overview of the project plan flow as well as 
overview of the resource’s assignments. 

It is a stand alone application that allows project managers to create project plans, assign 
resources and track the progress of the project according the project management theory. 
Seavus Project Planner is a step forward in the direction of Project Management and 
Enterprise Project Management (EPM).  

Seavus Project Planner is aimed to be a replacement for Microsoft® Project and Microsoft® 
Project Web Access as it provides similar functionalities available in these Microsoft’s 
applications and much more. Being a standalone application with powerful graphical display 
functionality similar to the display of Microsoft® Project’s Professional application, Seavus 
Project Planner can enable the team members and enterprise project professionals to have a 
powerful project tool that outperforms the Microsoft® Project Web Access in many ways and 
works in a similar Microsoft® Project Professional interface, but for a very affordable price.  
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FEATURES AT A GLANCE 

CREATING TASKS 
Tasks are one of the main elements in the project. Depending in which view the user is 
working, tasks can have different graphical representation: bars in Gantt Chart, Milestone 
Rollup, Milestone Data Rollup and Calendar and boxes in Network Diagram, Descriptive 
Network Diagram and Relationship Diagram. 

The purpose of this feature is to allow user to create tasks from different parts of the 
application. 

You can create Tasks: 

• from Gantt Table 

• in Gantt Chart 

• in the other Task Category Views 

INSERTING RESOURCES 
Resources are the second basic element of the project plan. They can be classified into two 
categories: Work (human resources) and Material (equipment, money, etc.). 

The purpose of this feature is to allow user to insert resources from different parts of the 
application. 

You can insert Resources: 

• in the Resource Sheet view 

• in the Resource form 

• in the Resource Name form 

• from Task Category views 

CREATING ASSIGNMENTS 
Tasks and Resources create Assignments, which are the final stage of the project’s creation. 
The assignments can be created from several views in SPP. 

You can create Assignments: 
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• from Gantt Chart 

• from Task form 

• from Task Name form 

• from Task Detail form 

SUPPORTED FILE FORMAT 
Seavus Project Planner saves the created plans in .SPP file format, which is the native file 
format for this application. 

MASTER PROJECT 
Seavus Project Planner supports inserting other projects (sub-projects) within your existing 
project (Master project). 

RESOURCE POOL 
You can create shared resource pool from the resources in your project and use them as 
resources in other projects so you can have precise information regarding their allocation. 

IMPORTING FILES 
With the Seavus Project Planner, beside the original native .spp file format, you can also 
import projects created in Microsoft Project (.mpp) and Microsoft XML files (.xml). 

The Import option is located under File menu. After selecting this option, new dialog window 
will open, where the user can browse the appropriate file. 

GOOGLE APPS INTEGRATION 
Seavus Project Planner integrates with Google Apps, allowing users to collaborate and share 
project information between them. The uploaded project files are stored in Google Doc 
making them available while working in your office, at home or while you are on the road. 

PROGRAM OPTIONS 
Gives you configuration options for Seavus Project Planner as well as for the currently opened 
project file. It can be accessed through the Options command on the Tools menu and it 
contains four tabs: General, View, Calendar and Calculation. 
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QUICK BARS 
These options are designed to help you when working only with your keyboard. By using these 
options you can gain quick and easy access to most common used options with using the 
function keys. Navigation is done with the arrow keys. You can access from the Quick Bars by 
pressing Esc. 

• Views quick bar can be accessed from F3 function key 

• Standard quick bar can be accessed from F4 function key 

• Structuring quick bar can be accessed from F5 function key 

COMBINED VIEWS 
Combined views is option that enables displaying of two views at the same time. The bottom 
pane view shows detailed information about the tasks or resources in the top pane view. 
Combination views can be created in Seavus Project Planner by using the Split action on the 
Window menu. Alternatively, you can activate the combined view functionality by dragging 
the split bar up, as shown on the figure below, which can be found in the bottom down corner 
of the application window, between the horizontal and vertical scrollbars. 

TIMESCALE AND ZOOM 
Some views, such as the Gantt Chart, have a timescale at the top. For the moment, the 
timescale in Seavus Project Planner displays two tiers: a top tier and a bottom tier.  

Currently, there are three levels of zoom in Seavus Project Planner: 

• Top tier shows days, Bottom shows hours. 

• Top tier shows weeks, Bottom shows days (default zoom level). 

• Top tier shows months, Bottom shows weeks. 

LAYOUT FORMATTING 
In some views (Chart based views and Network Diagram based views), Seavus Project Planner 
enables you to change the layout of the chart, i.e. the bars/boxes laid out in the 
chart/diagram portion of the view. You can change the layout options for the active view 
usually by using right-clicking on the bar or the diagram node for the corresponding view and 
choosing Format Bar or Box option, depending on the current view. 
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FORMATTING CHART BARS 
In any of the Gantt Chart views, you can change the layout options of the bars for the active 
view in Seavus Project Planner. You can open the Format Bar dialog by right-clicking on the 
bar and choosing Format Bar option. 

FORMATTING DIAGRAM BOXES 
In any of the Network Diagram views, you can change the layout options of the diagram boxes 
(nodes) for the active view in Seavus Project Planner. You can open the Format Box dialog by 
right-clicking on the box (node) and choosing Format Box option. 

FORMATTING COLUMN INFORMATION 
Column layout can be also formatted. You can initialize the Column Settings Dialog from the 
Format menu, by choosing Column Settings option. 

INFORMATION DIALOGS 
Seavus Project Planner provides the option to quickly review the scheduling option and other 
information about the project, tasks, resources, and assignments through the various 
information dialogs available in the application.  

Following information dialogs are available: Task Information, Resource Information, Project 
Statistics and Assign Resource Dialog. 

The information dialogs can be opened directly by double-clicking the selected task or 
resource, or for opening Task Information and Task Notes from the Project menu and the 
Standard toolbar. 

PRINTING 
To manage a project effectively, you may need to communicate project information to a 
variety of people. With Seavus Project Planner, you can print views and reports that present 
the exact information you want. 

The process of printing the information you need can be as simple as clicking a button or as 
refined as customizing and previewing the existing views. 

STRUCTURING OPTIONS 
These options are very helpful for better organizing of your project so the entered information 
can be more readable and project its self easier to navigate. 
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The Structure options you can access from the Project menu, Structure sub-menu or directly 
from the toolbars by clicking the options icons. With them you can: Indent and Outdent 
selected task, Show or Hide Subtasks. 

OUTLINING 
Seavus Project Planner supports up to 17 outline levels. 

SUMMARY TASKS 
In order to make visible representation of a group of tasks with specific requirements, user is 
separating them from other tasks with summary task. The purpose of the feature is to allow 
the user to create summary task in SPP. 

Creation of summary task is possible from the Gantt Chart view by using the indent-outdent 
feature. The summary task will be created by selecting the tasks under the task that is going 
to be summary and clicking on the icon for the “Indent” feature. 

To transform the summary task into ordinary task, user can select the summary task and click 
on the outdent icon. You can also create summary task for several sub-summary tasks. 

CHANGING WORKING TIME 
Having a flexible project working time is essential for creating proper assignments to your 
team members. The Change Working Time dialog in Seavus Project Planner enables you to 
modify existing predefined calendars or create your own new calendar that will meet all your 
needs. 

This dialog is located under the Tools menu. 

TASK DEPENDENCES 
When one task cannot start before another finishes, we say that those tasks are linked – 
dependent. The first task that needs to finish is called predecessor, while the task that comes 
after is called successor. 

With Seavus Project Planner you are also able to create task dependences between two or 
more tasks.  

SEARCH OPTIONS 
These options are presented through the following choices in the Edit menu: Find, Replace 
and Go To. 
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USER INTERFACE STYLES 
In order to make Seavus Project Planner User interface more interesting, we have applied five 
different styles that are available to you in the View menu, Style sub-menus. 

CREATE BASELINE 
This is a wizard that can be found in the Tools menu and with it you can create New Base line 
from current project, Change current Base line or Return to previously saved Base line  

You can create unlimited number of BaseLines. 

LICENSE DEACTIVATION 
If you are planning to replace or format your PC and you want to move your previously 
activated Seavus Project Planner to your new PC or to another machine, you will need to 
deactivate your license first so you can re-use it on your new PC. 
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FEATURES LIST 
 

Feature Description 
Application type Stand-alone desktop application for creating project plans. 

Supported file 
format 

SPP - native Seavus Project Plan file format 

Importing Support for importing project plan from:  
• Microsoft® Project MPP 
• Microsoft® Project XML 

Views Main Views: Calendar, Gantt Chart, Network Diagram, 
Resource Graph, Resource Sheet, Task Usage, Resource 
Usage 
More Views: Relationship Diagram, Descriptive Network 
Diagram, Task Sheet, Milestone Rollup, Milestone Date 
Rollup 
Forms: Task Details, Task Form, Task Name, Resource 
Form, Resource Name 

Reports General: Project Info, Critical Tasks, Milestones, Working 
Weeks, Milestones 
Present Activities: Unstarted Tasks, Tasks In Progress, 
Completed Tasks 
Assignments: Who Does What, Who Does What When, To Do 
List 
Costs: Earned Value, Budget 

Tables Task: Cost, Entry, Hyperlink, Schedule, Summary, 
Tracking, Usage, Variance, Work 
Resource: Cost, Entry, Hyperlink, ProjectOffice.net, 
Summary, Usage, Work 

Filters Task: All Tasks, Task Range, By Resource, Completed 
Tasks, Incomplete Tasks, Critical Tasks, Summary Tasks, 
Milestones Tasks, Date Range, Tasks with Attachments 
Resource: All Resources, Overallocated Resources, Work 
Resources, Material Resources, Attached Resources 

Groups Task: Complete and Incomplete, Critical, Duration, 
Milestones, No Group, Priority 
Resource: No Group, Resource Type Group 

Project Statistics Displays information about project’s: 
• Current status 
• Duration 
• BaseLine 
• Actual Work 
• Actual Cost 
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• Remaining Work 
• Remaining Cost 
• Variance 
• Percentage complete 

Customizable Forms Available in Customizable Forms toolbar: 
• Entry Dialog 
• Cost Dialog 
• Work Dialog 
• Tracking Dialog 
• Link Dialog 

Tracking Available in Tracking Toolbar to enter predefined 
%complete: 

• Now (to current date and time) 
• 0 % 
• 25 % 
• 50 % 
• 75 % 
• 100 % 

Printing Complete support for printing, along with print preview 
and page setup options for all views and reports. 
 
Page Setup dialog options: 
• Page settings: orientation, scaling (adjust to N% normal 

size, or fit to N pages wide by M pages tall), First Page 
Number, Paper Size 

• Margins: Top, Bottom, Left, Right 
• Header settings: alignment of the text (left, center, 

right), insert page number, total pages, date, time, file 
name. 

• Footer settings: alignment of the text (left, center, 
right), insert page number, total pages, date, time, file 
name 

• View settings: Show borders, Print Notes, Print Legend 
Outlining Seavus Project Planner supports up to 17 outline levels 

Task Operations Seavus Project Planner supports the following task 
operations: 

Link Task 

Unlink Task 

Split Task 

Outdent Task 

Indent Task 

Find&Replace and Complete support for searching through any task or 
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Go To resource fields and replacing of text. 

Go To functionality supports positioning directly to a task 
(by ID), to a location on the timeline (by date). 

Zoom 3 levels available: 

Top tier: Months, Bottom tier: Weeks 

Top tier: Weeks, Bottom tier: Days 

Top tier: Days, Bottom tier: Hours 

Fonts and 
background 
formatting 

Available font formatting (choose font, size, style, color), 
paragraph aligning, choosing cell background color 

Resizing columns 
and rows 

Any table can be resized by dragging the row/column/tier 
separator in the desired direction. 

Table columns can be auto-sized to adjust to the contents 
of the field by double-clicking on the column separator. 

Information dialogs Seavus Project Planner implements the following 
information dialogs: 

Task Information 

Resource Information 

Project Statistics 

Assign Resource Dialog 

Program options The following configuration options can be changed in 
Seavus Project Planner: 

Spell checking and dictionaries 

Date format (for displaying dates) 

Default topmost view 

Default bottom view 

Default Start and End working time of the day 

Hours per day 

Hours per week 
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Days per month 

Project calendar 

Default fixed costs accrual 

Leveling calculation options 

Currency options (symbol, decimal digits, and placement) 

Number of decimal digits 

Combined views Support for creating combined views in Seavus Project 
Planner by splitting the window in two panes, each 
containing a different view, where the bottom pane view 
shows detailed information about the tasks or resources in 
the top pane view 

Online help An extensive and modern help manual, integrated with the 
application. It provides reference information for the 
features, along with overviews and best use scenarios for 
using a particular view or functionality. 

Check for Updates A Live Update system, which ensures that the application 
is kept up to date with all new features and updates. 
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SYSTEM REQUIREMENTS 
To use the Seavus Project Planner to create your Seavus Project Planner files (.spp) you will 
need the following: 

Processor 

• Intel® Pentium-grade or higher, or Athlon Processor. 

Operating System 

• Microsoft Windows 7 

• Microsoft Windows Vista 

• Microsoft Windows 2000 Professional/Server 

• Microsoft Windows XP Professional/Home 

• Microsoft Windows Server 2003 

• Microsoft Windows Server 2008 

Memory 

• Minimum of 512MB of RAM (higher recommended) 

Hard Disk 

• Minimum of 150MB of available hard-disk space 

Display 

• SVGA (800 × 600) or higher-resolution monitor 

Seavus Group 

Skeppsbron 5  

211 10 Malmoe, Sweden  

Phone: + 46 (0) 40-300-940  

Fax:     + 46 (0) 40-300-941    

Email: support@seavusprojectplanner.com   

URL: www.seavusprojectplanner.com 

All documents prepared or furnished by Seavus Group and the copyright therein shall remain the property of Seavus Group. 

mailto:support@seavusprojectplanner.com
http://www.seavusprojectplanner.com/
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